Intermittent DMS & Web Connectivity
Incident Report for
Click Dealer
Resolved
This incident is now resolved.
Many thanks for your patience
Posted
Feb
06
,
2026
-
12:37
GMT
Monitoring
Normal service has now resumed, and we will continue to monitor.
Many thanks for your patience
Posted
Feb
06
,
2026
-
12:15
GMT
Investigating
We are currently investigating intermittent connectivity issues with DMS & Website.
We’ll update this page with further information when available.
Please monitor this page for further updates.
Posted
Feb
06
,
2026
-
11:59
GMT
This incident affected: ClickWeb and ClickDMS.
×
Subscribe to Incident
Subscribe to updates for
Intermittent DMS & Web Connectivity
via . You'll receive .