Intermittent Mail C Connectivity
Incident Report for
Click Dealer
Resolved
This incident has been resolved.
Posted
Sep
03
,
2026
-
15:18
BST
Monitoring
A fix has been implemented and we are continuing to monitor the results.
Many thanks for your patience
Posted
Sep
03
,
2026
-
14:09
BST
Investigating
We are currently investigating an intermittent connectivity issue accessing webmail via one of our mail servers.
We’ll update this page with further information when available.
Please monitor this page for further updates.
Posted
Sep
03
,
2026
-
12:58
BST
This incident affected: Mail Servers (Mail Server (C)).
×
Subscribe to Incident
Subscribe to updates for
Intermittent Mail C Connectivity
via . You'll receive .