cPanel have released a fix for this issue and after testing we can confirm successful login to Webmail via Safari.
Many thanks for your patience
Posted Jun 30, 2026 - 15:29 BST
Identified
Webmail Alert: we have an open support ticket with cPanel about Webmail not being accessible in some versions of Safari and will update this page when we receive any updates.
As a temporary workaround, please use Google Chrome of Firefox, which are both fully functional and working as expected.
Alternatively, in Chrome you can add :2096 to the end of your webmail link which should allow access via Chrome. e.g. webmail.domainname.co.uk:2096
Many thanks for your patience
Posted Jun 16, 2026 - 10:21 BST
Investigating
Webmail Alert: We are currently investigating an issue affecting webmail access for users on Safari. As a temporary workaround, please use Google Chrome, which is fully functional and working as expected.
Posted Jun 11, 2026 - 10:03 BST
This incident affected: Mail Servers (Mail Server (A), Mail Server (B), Mail Server (C)).