Finance Calculator Display Issue

Incident Report for Click Dealer

Resolved

This incident has been resolved.
Posted May 16, 2026 - 18:44 BST

Update

We are continuing to work on a fix for this issue.
Posted May 15, 2026 - 11:30 BST

Identified

We're aware of an issue affecting some third party calculators. Our team are actively investigating and working on a resolution.
Posted May 15, 2026 - 11:30 BST
This incident affected: Other - Third Party.