Intermittent Issue Sending Email

Incident Report for Click Dealer

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 14:41 GMT

Monitoring

Normal service has now resumed, and we will continue to monitor.
Posted Mar 25, 2026 - 12:55 GMT

Investigating

We are currently investigating an intermittent issue sending emails from one of our mail servers. We will update this page with further information when available, please monitor this page for further updates.
Posted Mar 25, 2026 - 10:51 GMT
This incident affected: Mail Servers (Mail Server (A)).