ClickWeb and DMS Intermittent Connectivity

Incident Report for Click Dealer

Resolved

This incident is now resolved.
Many thanks for your patience
Posted Jun 25, 2025 - 11:14 BST

Monitoring

Normal service has now resumed, however we will continue to monitor.
If you are still experiencing this issue, please email help@clickdealer.co.uk
Posted Jun 25, 2025 - 08:55 BST

Identified

We have identified the cause with ClickWeb and DMS and are actively working on a solution.
We’ll update this page with further information when available.
Please monitor this page for further updates.
Posted Jun 25, 2025 - 08:47 BST

Monitoring

Normal service has now resumed, and we will continue to monitor.
If you are still experiencing this issue, please email help@clickdealer.co.uk
Posted Jun 25, 2025 - 08:40 BST

Investigating

We are currently investigating an intermittent connectivity issue with DMS and Websites.
We’ll update this page with further information when available.
Please monitor this page for further updates.
Posted Jun 25, 2025 - 08:37 BST
This incident affected: ClickWeb and ClickDMS.