Mail B

Incident Report for Click Dealer

Resolved

This incident has been resolved.
Posted May 20, 2026 - 15:12 BST

Monitoring

Microsoft have taken action to unblock the impacted instance but it can take 24-48 hours to fully take effect. However, after completing tests we are able to successfully send to the accounts previously affected. We will continue to monitor for the next 24-48 hours
Posted May 19, 2026 - 19:13 BST

Update

We are currently communicating with Microsoft to resolve this issue and will provide further updates as soon as we can.

We recommend you maintain active communication with your customers who have a office/hotmail/live email address to ask for an alternative email account for them. You could temporarily use an alternative business email address to send emails to office.com hotmail.co.uk and live.co.uk.

Many thanks for your patience
Posted May 19, 2026 - 08:23 BST

Identified

We have identified the cause and raised a ticket with Microsoft to resolve as this is outside of Click Dealer's control. We would recommend you maintain active communication with your customers who have a office/hotmail/live email address to ask for an alternative email account for them. You could temporarily use an alternative business email address to send emails to office.com hotmail.co.uk and live.co.uk.
Posted May 18, 2026 - 09:25 BST

Investigating

We are currently investigating an issue affecting the ability to send emails to office.com, hotmail.co.uk and live.co.uk email addresses affecting a small number of dealers using our mail services. Our engineering team are investigating this as high priority and we will provide an update as soon as possible.
Posted May 18, 2026 - 09:24 BST
This incident affected: Mail Servers (Mail Server (B)).