Email Delivery To Hotmail & Live Email Addresses
Incident Report for Click Dealer
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 10:52 BST
Monitoring
Microsoft have taken action to unblock the impacted instance but can take 24-48 hours to fully take effect. We will continue to monitor.
Posted Sep 26, 2024 - 13:02 BST
Identified
We have identified the cause and raised a ticket with Microsoft to resolve as this is outside of Click Dealer's control.

We would recommend you maintain active communication with your customers who have a hotmail/live email address to ask for an alternative email account for them. You could temporarily use an alternative business email address to send emails to hotmail.co.uk and live.co.uk.
Posted Sep 26, 2024 - 11:14 BST
Investigating
We are currently investigating an issue affecting the ability to send emails to hotmail.co.uk and live.co.uk email addresses affecting a small number of dealers using our mail services. Our engineering team are investigating this as high priority and we will provide an update as soon as possible.
Posted Sep 26, 2024 - 10:34 BST
This incident affected: Mail Servers (Mail Server (C)).