Intermittent DMS & Web Connectivity

Incident Report for Click Dealer

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 11:33 GMT

Investigating

We are currently investigating an issue with intermittent Website and DMS connectivity, please monitor this page for further updates.
Many thanks for your patience
Posted Feb 11, 2026 - 11:28 GMT
This incident affected: ClickWeb and ClickDMS.