DMS Logging In

Incident Report for Click Dealer

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 08:57 BST

Monitoring

A fix has been implemented and we're now monitoring the system.
Posted Jun 17, 2025 - 08:55 BST

Identified

The issue has been identified and our team are actively working on a fix.
Posted Jun 17, 2025 - 08:37 BST

Investigating

We are currently investigating an issue with some users having issues accessing the DMS. Our team are actively investigating. We will update this page with further information when available, please monitor this page for further updates.
Posted Jun 17, 2025 - 08:35 BST
This incident affected: ClickDMS.