Email

Incident Report for Click Dealer

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 11:52 GMT

Update

The temporary block will remain in place on any emails from auca.com by Click Dealer hosted emails. We will continue to review over the coming days. Thanks in advance for your understanding
Posted Mar 16, 2026 - 15:11 GMT

Update

We have put a temporary block in place on any emails from auca.com by Click Dealer hosted emails. We will review over the coming days. Thanks in advance for your understanding
Posted Mar 13, 2026 - 16:27 GMT

Monitoring

Normal behaviour has resumed on our mail servers, many thanks for your patience.
Posted Mar 13, 2026 - 15:38 GMT

Investigating

We are currently investigating an intermittent issue on our mail servers.

Please monitor this page for further updates.

Many thanks for your petience
Posted Mar 13, 2026 - 14:21 GMT
This incident affected: Mail Servers (Mail Server (A), Mail Server (B), Mail Server (C)).