Finance Calculator Display Issue

Incident Report for Click Dealer

Resolved

The issue has been resolved and calculators are working as normal.
Posted Apr 03, 2026 - 05:18 BST

Identified

We've identified the issue and a fix is being put into place. We expect this to be resolved shortly.
Posted Apr 02, 2026 - 21:38 BST

Investigating

We're aware of an issue with some finance calculators not displaying correctly on the website. We're investigating this currently.
Posted Apr 02, 2026 - 20:17 BST
This incident affected: ClickWeb.