Finance Calculator Display Issue

Incident Report for Click Dealer

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 13:52 BST

Investigating

We're aware of an issue affecting some third party calculators. Our team are actively investigating and working on a resolution.
Posted Jul 03, 2026 - 10:25 BST
This incident affected: Other - Third Party.