Finance Calculator Display Issue
Incident Report for
Click Dealer
Resolved
A fix has been implemented by the finance calculator provider, and they are now working as expected.
Posted
Apr
03
,
2026
-
13:30
BST
Investigating
we’re aware of an issue with some finance application forms not loading. The calculator provider is currently investigating.
Posted
Apr
03
,
2026
-
12:52
BST
This incident affected: ClickWeb.
×
Subscribe to Incident
Subscribe to updates for
Finance Calculator Display Issue
via . You'll receive .